CRON - Godaddy 10 years 10 months ago #1

  • Nicolas
  • Localtime: 21:21
  • Europe/Bucharest
  • Posts: 14
If your host your site on Godaddy and that your RSS Factory pseudocron is not updating your feeds, create a Cron Job in your Hosting Control Center > Content>Cron manager.

First of all, test your pseudo url (See: Refresh Tab of the Configuration of RSS Factory component) in your browser.Ex.:

http://www.[]yourwebsite.com/index.php?option=com_rssfactory&task=refresh&password=[yourpassword]

If not working search for similar post in the forum.
If working add a Cron job in your Godaddy Hosting Control Center.

In the Command line, will NOT work:
- the absolute server path for your website (Ex.: /home/content/a/b/c/abcxyz/html/ for the root instead of http://www.[site].com
- the 'lynx' command (Ex.:lynx -accept_all_cookies -dump 'http://[site].com/index.php?option=com_rssfactory&task=refresh&password=[password]'

In the Command line, will WORK CORRECTLY:
- the 'wget' command line with single or double /
Examples:
wget "http://www.[site].com/index.php?option=com_rssfactory&task=refresh&password=[password]"
or
wget "http://[site].com//index.php?option=com_rssfactory&task=refresh&password=[password]"

You will receive a confirmation mail like this:

--08:30:01--  http://[site].com//index.php?option=com_rssfactory&task=refresh&password=[password]
          => `index.php?option=com_rssfactory&task=refresh&password=[password].xx'
Resolving touchcf.com... 68.178.211.7
Connecting to touchcf.com|68.178.211.7|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [text/html]

    0K .......... .......                                      52.30 MB/s

08:30:23 (52.30 MB/s) - `index.php?option=com_rssfactory&task=refresh&password=[password].30' saved [18373]


NOTE:
The effective Refresh timer will be the one from your Cron Job and no more from the RSS Factory setting (Pseudocron refresh timer:Important)
The administrator has disabled public write access.

Re: CRON - Godaddy 10 years 10 months ago #2

  • karl hoelscher
  • Localtime: 21:21
  • Europe/Bucharest
  • Posts: 15
welll... tried this.....

and i get this...

/bin/sh: wgethttp://www.thecitizenadvisor.com//index.php?option=com_rssfactory&task=refresh&password=pass: No such file or directory

godaddy support no help either.....
The administrator has disabled public write access.

Re: CRON - Godaddy 10 years 10 months ago #3

  • Nicolas
  • Localtime: 21:21
  • Europe/Bucharest
  • Posts: 14
For Godaddy, it's normal that they cannot give support for external applications.

Seems that you have introduce the following command line:

wgethttp://www.thecitizenadvisor.com//index.php?option=com_rssfactory&task=refresh&password=pass

But it should be:

wget "www.thecitizenadvisor.com//index.php?opt...h&password=pass";

with the space and the "

Also supposing that in the pseudocron settings of RSSFactory, your password is pass (if different, adapt your command line)

Hope helps
The administrator has disabled public write access.