• Page:
  • 1
  • 2

Re: New User - Can't Get Photo Battle Working 7 years 8 months ago #11

  • Codruta K.
  • Codruta K.'s Avatar
  • Developer
  • Bucharest, Romania
  • Localtime: 12:46
  • Europe/Bucharest
  • Posts: 1006
Hello,
The modules are set to display on all photo battle menu pages.
means that when you click on any menu item link, the modules will be displayed on that page.
But links from modules are not included in photo battle menu items.

for jpg requests:
Edit components/com_photobattle/views/show/tmpl/default.php and delete or comment out lines 188-190:
<div style="text-align: center;">
    <img alt="link0" src="<?php echo JURI::root(); ?>components/com_photobattle/assets/images/link.png" class="photobattle-icon" /><?php echo JText::_('SHARE_LINK'); ?>:
    <input name="share-link0" id="share-link0" value="<?php echo JURI::root(); ?>index.php?option=com_photobattle&task=pageinfo&id=<?php echo $this->image[0]['id']; ?>&source=<?php echo $this->image[0]['source']; ?>&Itemid=<?php echo $this->Itemid; ?>" style="width: 260px; "/>
  </div>

AND for pair image
<div style="text-align: center;">
    <img alt="link1" src="<?php echo JURI::root(); ?>components/com_photobattle/assets/images/link.png" class="photobattle-icon" /><?php echo JText::_('SHARE_LINK'); ?>:
    <input name="share-link1" id="share-link1" value="<?php echo JURI::root(); ?>index.php?option=com_photobattle&task=pageinfo&id=<?php echo $this->image[1]['id']; ?>&source=<?php echo $this->image[1]['source']; ?>&Itemid=<?php echo $this->Itemid; ?>" style="width: 260px; "/>
  </div>

For category images,
Edit components/com_photobattle/views/show/tmpl/default.php and delete or comment out line (~)182:
<img src="<?php echo JUri::root(); ?>components/com_photobattle/upload/icons/<?php echo $this->image[0]['category_icon']; ?>" />

AND (~)428:
<img src="<?php echo JUri::root(); ?>components/com_photobattle/upload/icons/<?php echo $this->image[1]['category_icon']; ?>" />
thePHPfactory Customer Support
The administrator has disabled public write access.

Re: New User - Can't Get Photo Battle Working 7 years 8 months ago #12

  • vickiwatson
  • Localtime: 12:46
  • Europe/Bucharest
Okay, got those things straightened out.

I used the metamod module to get the modules to display on all photo battle pages.

Maybe last question!

The comments are not working. :(

I get a popup dialog with a 0 in it. It says please wait, comments are being loaded, but doesn't add the comment. See screenshot...

www.christiancowgirl.net/images/photo-battle3.jpg
The administrator has disabled public write access.

Re: New User - Can't Get Photo Battle Working 7 years 8 months ago #13

  • vickiwatson
  • Localtime: 12:46
  • Europe/Bucharest
Anyone had a chance to look at this? I think this is the last thing that's stopping me from making this available on the website.

Also, just curious whether whatever changes you made will be wiped out with future updates of Photo Battle?
The administrator has disabled public write access.

Re: New User - Can't Get Photo Battle Working 7 years 8 months ago #14

  • Codruta K.
  • Codruta K.'s Avatar
  • Developer
  • Bucharest, Romania
  • Localtime: 12:46
  • Europe/Bucharest
  • Posts: 1006
I guess you checked the site.

There is just comment navigation to be solved.
All changes will be in next versions.

Problem is solved now. It was your template's pagination file that generated the issue.
thePHPfactory Customer Support
The administrator has disabled public write access.

Re: New User - Can't Get Photo Battle Working 7 years 8 months ago #15

  • vickiwatson
  • Localtime: 12:46
  • Europe/Bucharest
:( I still get the dialog popping up with a 0 in it.

Comments show up on the front end, but there are no comments listed in the Photo Battle comments tab on the back end.
The administrator has disabled public write access.

Re: New User - Can't Get Photo Battle Working 7 years 8 months ago #16

  • Codruta K.
  • Codruta K.'s Avatar
  • Developer
  • Bucharest, Romania
  • Localtime: 12:46
  • Europe/Bucharest
  • Posts: 1006
Please clear the cache and try again. I tested and is no dialog popup.

Photo Battle comments tab is just for Reported comments or for settings. There is no comment list in the back end.
thePHPfactory Customer Support
The administrator has disabled public write access.

Re: New User - Can't Get Photo Battle Working 7 years 8 months ago #17

  • vickiwatson
  • Localtime: 12:46
  • Europe/Bucharest
Okay, sorry about that. I cleared the cache and it is working now.  :-*
The administrator has disabled public write access.
  • Page:
  • 1
  • 2