UTF-8 1 week 1 day ago #1

  • mandyhof
  • Localtime: 14:37
  • Europe/Bucharest
  • Posts: 4
Hello,
how to change encoding to UTF-8?
Im translate blog to Czech language, not working letters as ě,š,č,ř,ž,ý,á,í,é,...and so on... (edit in en_EN file .ini)

Thank you for your help :))
Monika
The administrator has disabled public write access.

UTF-8 1 week 1 day ago #2

  • Alexandru
  • Alexandru's Avatar
  • Senior Developer
  • Bucharest
  • Localtime: 14:37
  • Europe/Bucharest
  • Posts: 4557
Hello!

This is not related to our extension. The extension does not change the encoding. As you can see in the screenshot, those letters are displayed properly on our local test server.

Are those letters working in other parts of Joomla?
thePHPfactory Customer Support
The administrator has disabled public write access.

UTF-8 1 week 19 hours ago #3

  • mandyhof
  • Localtime: 14:37
  • Europe/Bucharest
  • Posts: 4
When i change text in /www/language/en-EN/en-GB.com_blogfactory.ini

COM_BLOGFACTORY_BLOGS_BLOG_SUBSCRIBE="subscribe"
to
COM_BLOGFACTORY_BLOGS_BLOG_SUBSCRIBE="odebírat"

Will be displayed:
odeb�rat
The administrator has disabled public write access.

UTF-8 1 week 14 hours ago #4

  • Alexandru
  • Alexandru's Avatar
  • Senior Developer
  • Bucharest
  • Localtime: 14:37
  • Europe/Bucharest
  • Posts: 4557
It seems in your screenshot that another letter (ř) is displayed properly.

Make sure that you are using an UTF editor that saves the file properly.
thePHPfactory Customer Support
The administrator has disabled public write access.

UTF-8 1 week 6 hours ago #5

  • mandyhof
  • Localtime: 14:37
  • Europe/Bucharest
  • Posts: 4
It works...Thank you so much! :)
The administrator has disabled public write access.

UTF-8 1 day 5 hours ago #6

  • mandyhof
  • Localtime: 14:37
  • Europe/Bucharest
  • Posts: 4
Please - I have a final question.
How do I change the date encoding?
The administrator has disabled public write access.

UTF-8 1 day 3 hours ago #7

  • Alexandru
  • Alexandru's Avatar
  • Senior Developer
  • Bucharest
  • Localtime: 14:37
  • Europe/Bucharest
  • Posts: 4557
There is no encoding set on that date. That text is displayed using Joomla's date class.

Please make sure that the language files you have edited are being saved using a UTF editor.
thePHPfactory Customer Support
The administrator has disabled public write access.