Beginner questions 2 years 2 months ago #1

  • MacRicky
  • Localtime: 19:57
  • Europe/Bucharest
  • Posts: 10
Goodmorning,
I installed successfully the Blog Factory Menu. However I'm not that keen with Joomla and therefore I want to advance easily with the minimum of options. Could you help me using easy words?
Blog Factory Menu:
- Is it possible to make all items except Posts invisible and if so how to do this?
Posts:
On the right you have a small icon (next to comments). If you click this button I get an error that I'm not able to visit this page. What does this button do and how can I make it invisible?
If I want to make a comment I see a button via an envelope and subscribe. How can I make this invisible?
Under settings I only enabled the Guest View.
Best regards,
Richard
The administrator has disabled public write access.

Beginner questions 2 years 1 month ago #2

  • Alexandru
  • Alexandru's Avatar
  • Senior Developer
  • Bucharest
  • Localtime: 19:57
  • Europe/Bucharest
  • Posts: 4570
Hello!

1. You can manage the menu items from the Backend Joomla Menu Manager.
2. What is the label of the button?
3. If you want to hide the subscribe button edit [Joomla dir]/components/com_blogfactory/views/post/tmpl/default.php and delete or comment out lines:
<a href="<?php echo BlogFactoryRoute::task('blog.subscribe&id=' . $this->item->blog_id); ?>"
       rel="<?php echo $this->subscribed; ?>" class="button-subscribe">
        <i class="factory-icon-mail"></i><span><?php echo BlogFactoryText::plural('blogs_blog_subscribe', $this->subscribed); ?></span>
    </a>
thePHPfactory Customer Support
The administrator has disabled public write access.

Beginner questions 2 years 1 month ago #3

  • MacRicky
  • Localtime: 19:57
  • Europe/Bucharest
  • Posts: 10
Hey Alenandru,

Thank you very much for replying all my questions. They solved almost everything!

I can't find a label for the button/icon in the posts section. However thanks to your suggestion the button under the comments is now hidden.
How can I remove the same button in the main posts, see attachment?

The posts section and comments is now active and working fine but is it possible to receive a message by email if someone has posted a comment?

Thank you for this excellent piece of software !
Richard
The administrator has disabled public write access.

Beginner questions 2 years 1 month ago #4

  • Alexandru
  • Alexandru's Avatar
  • Senior Developer
  • Bucharest
  • Localtime: 19:57
  • Europe/Bucharest
  • Posts: 4570
1. Edit [Joomla dir]/components/com_blogfactory/views/posts/tmpl/default_post.php and remove or comment out
<span class="blogfactory-post-info-item"><a href="<?php echo BlogFactoryRoute::view('blog&id=' . $this->item->blog_id . '&alias=' . $this->item->blog_alias); ?>"><i class="factory-icon-blog"></i><?php echo $this->item->blog_title; ?></a></span>

2. Check out the notifications sections for existing notifications.
thePHPfactory Customer Support
The administrator has disabled public write access.

Beginner questions 2 years 1 month ago #5

  • MacRicky
  • Localtime: 19:57
  • Europe/Bucharest
  • Posts: 10
Thank you Alexandru for this fast reply and solution!

My Posts/Comments is now up and running...
Probably more questions may follow but this threat may be closed.
The administrator has disabled public write access.

Beginner questions 2 years 1 month ago #6

  • Erik Folberth
  • Project Manager
  • Bukarest, Rumänien
  • Localtime: 19:57
  • Europe/Bucharest
  • Posts: 4949
Hi,

if you have the time, we would be happy to receive a review under:
extensions.joomla.org/extensions/extensi...t/blog/blog-factory/

The better the rating, more users will use the extension, so that we can maintain and offer support further for it.

Thank you!
thePHPfactory Team
Last Edit: 2 years 1 month ago by Erik Folberth.
The administrator has disabled public write access.

Beginner questions 2 years 1 month ago #7

  • John Wilson
  • Localtime: 19:57
  • Europe/Bucharest
  • Posts: 3
Hello, I installed Blog and the editor is missing the add image button. I have tried changing the assigned editor in joomla global config but the editor in the blog won't change and allow the addition of images. What is causing this? I wasn't able to post a ticket about this.
Regards,
John
Last Edit: 2 years 1 month ago by John Wilson.
The administrator has disabled public write access.

Beginner questions 2 years 1 month ago #8

  • Erik Folberth
  • Project Manager
  • Bukarest, Rumänien
  • Localtime: 19:57
  • Europe/Bucharest
  • Posts: 4949
@john
so first you put out of the blue a bad review on JED, lying that you contacted us in this regard and we did not answered and one day later, after posting the bad review you decided to ask also the question on our forum?!

If this is your way to support the community, first giving bad reviews, lying that you had no response from us, when you didn't even contacted us in this matter, all this on an extension which we freely maintain only for the benefit of the community and which had good ratings until yours, we feel badly that you decided to act this way, absolutely against the spirit of the Joomla community!
thePHPfactory Team
The administrator has disabled public write access.

Beginner questions 2 years 1 month ago #9

  • John Wilson
  • Localtime: 19:57
  • Europe/Bucharest
  • Posts: 3
What you have done is against the spirit of the joomla community. Don't bother putting up free extensions etc that you don't want to support and allow people to contact you about. I am fed up with "developers" hiding their contact details when they release extensions or making it so bloody difficult. I spent the best part of an hour looking for a way to send you an email but you dont want to field questions about your free product. Well dont post it in the extensions. Don't waste peoples time with it as I have wasted my time with yours. Its uninstalled off my site, I'll gladly pay another developer for their product. I feel badly that I wasted my time with this.
The administrator has disabled public write access.

Beginner questions 2 years 1 month ago #10

  • Erik Folberth
  • Project Manager
  • Bukarest, Rumänien
  • Localtime: 19:57
  • Europe/Bucharest
  • Posts: 4949
You could have deleted the review and kindly ask for support today, but it seems you continue to insult us, although all what we've done is offer a free product which allot of Joomla community members benefit from.
With such attitude, insulting us and lying about us, you can go somewhere else.
We clearly state that support for free products it's offered ONLY on our forum!

You stated also yesterday that you uninstalled the extension on the review, but still today asking support and insulting us.
If you benefit for something for free, at least have the human decency not to lie and insult the developers.
We are in this business for over ten years and our support is always top, but if you think you can lie about us and insult us, you are at the wrong place.
thePHPfactory Team
The administrator has disabled public write access.